您的当前位置:首页 --> CSS
针对IE浏览器的兼容问题小结

怎么用一行代码解决CSS各种IE各种兼容问题

<meta http-equiv="x-ua-compatible" content="IE=edge, chrome=1"/>

X-UA-Compatible:是针对ie8新加的一个设置,对于ie8之外的浏览器是不识别的,这个区别与 content="IE=7"在无论页面是否包含<!DOCTYPE>指令,都像是使用了 Windows Internet Explorer 7 的标准模式。而content="IE=EmulateIE7"模式遵循<!DOCTYPE>指令。对于多数网站来说,它是首选的兼容性模式。为了避免制作出的页面在IE8下面出现错误,建议直接将IE8使用IE7进行渲染。也就是直接在页面的header的meta标签中加入如下代码:<meta http-equiv="X-UA-Compatible" content="IE=7" />这样我们才能使得页面在IE8里面表现正常!

IE=6/7/8.... 指定特定版本内核

IE=edge: 默认使用最新

这是一个,文档兼容模式的定义。Edge 模式告诉 IE 以最高级模式渲染文档,也就是任何 IE 版本都以当前版本所支持的最高级标准模式渲染,避免版本升级造成的影响。简单的说,就是什               么版本 IE 就用什么版本的标准模式渲染。

chrome=1:如果有装chrome就使用chrome的内核。使用以下代码强制 IE 使用 Chrome Frame 渲染<meta http-equiv="X-UA-Compatible" content="chrome=1">

 Google 官方提供了对 Google Frame 插件安装情况的检测,这里直接调用方法即可,如果检测到 IE 并未安装 Google Frame,则弹出对话框提示安装。
<script src="http://ajax.googleapis.com/ajax/libs/chrome-frame/1/CFInstall.min.js"></script><script>CFInstall.check();</script>
 提示 IE 用户安装 Google Frame

最佳的兼容模式方案,结合考虑以上两种:
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
 

IE的兼容性问题 :

在早起IE8之前,那个时候IE浏览器还属于比较独大的情况,那个时候他有很多东西是和网络的Standard不太一样。譬如他有自己才看的懂得自定义Tag。作为那个时代,很多网站都是以那个时候的IE作为目标浏览器去写的网页。

随著时间的进步,微软意识到自己搞自己的是不行的,需要跟Web Standard一样,慢慢的以前那些旧的只属于IE有的东西就在新的IE里面没有了。

但是为了以前浏览器而设计的网站要怎么办?他们就处于很尴尬的局面,因为如果不支持很多旧网站除了会跑版以外最要命是有些功能都会有问题。

为了解决这个问题,微软在IE8以后加入了所谓的兼容性模式,也就是能够在旧的网站使用兼容性模式浏览,而一切正常,而到比较新的网站就用正常模式浏览。

听起来很棒,有问题的旧网站使用IE 兼容模式,新网站使用正常模式。但是这个有一个前提,那就是使用者要知道兼容性模式的意义和如何切换。

 另外还有一起其他的解决方案,

例如google的ie7 – js中是一个JavaScript库(解决IE与W3C标准的冲突的JS库),使微软的Internet Explorer的行为像一个Web标准兼容的浏览器,支持更多的W3C标准,支持CSS2、CSS3选择器。它修复了许多的HTML和CSS问题,并使得透明PNG在IE5、IE6下正确显示。

使IE5,IE6兼容到IE7模式(推荐)

<!–[if lt IE 7]>

<script src=”http://ie7-js.googlecode.com/svn/version/2.0(beta)/IE7.js” type=”text/javascript”></script>

<![endif]–>

 

热门文章